Conjoint Analysis




Research question: To what extent does each
component (factor) contribute to the total utility of a
product?
Assumption:
Total utility = Sum of all partial utilities




Data base of the Conjoint Analysis are preferences of
the interviewed subjects
Important application: Design of a new product
according to the requirements of the market

Conjoint Analysis






Factors and their values are defined by the researcher
in advance
The various combinations of the factor values yield
fictive products that are being ranked by the
interviewed persons
With Conjoint Analysis it is possible to derive metric
partial utilities from the ranking results
The summation of these partial utilities therefore
results in metric total utilities

Conjoint Analysis




Independent variables: Object attributes
Dependent variable: Preferences of the interviewed
person for the fictive products
The utility structure of a number of persons can be
computed through aggregation of the single results

Conjoint Analysis
 Factors and Factor Values
Important for the choice of factors and their values are:
¾ Relevance
¾ Interference
¾ Independence
¾ Realisability
¾ Compensatory relationships of the various factor
values
¾ They do not constitute exclusion criteria
¾ Terminableness

Conjoint Analysis


Example: Attitudes towards dishwashing products
1. Clean: glass/dishes clean
2. Shiny: glass/dishes shiny
3. Smell: Non-perfumed/lemon fresh/intensive lemon
fresh
4. Quantity: small/medium/x-large
5. Packaging: loose in box/tab in plastic/tab in dissolving
plastic
6. Design: single/multi-colored/multi-colored + ball

Conjoint Analysis
 Survey Design
1.

Definition of the incentives
Incentive = Combination of factor values that is
presented for rating
¾ Profile method: incentive results from the
combination of the different factor values of each
factor
¾ Two-factor method (Trade-off Analysis): Only two
factors are used at a time. For each of these
pairs a Trade-off-Matrix is set up
Which method is used depends on how demanding
the interview is for the respondent, the expenditure
of time and the closeness to reality

Conjoint Analysis
 Survey Design
2.

Number of incentives
¾ Can increase very fast depending on the number
of factors and their values. It is advisable to
choose a subset (reduced design) out of all
theoretically possible incentives (full design).
There shouldn’t be more than 20 fictive products.
¾ Choice of the number can be based on random
selection (not very common) or systematic
selection
¾ Possible are symmetric (= all factors have the
same number of values) and asymmetric
(divergent number of values) designs
¾ Addelman developed several “Basic Plans” for
the construction of reduced asymmetric designs
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Example (cont.): Attitudes towards dishwashing
products
¾ The full design consists of 2x2x3x3x3x3=324
different incentives
¾ The reduced design consists of 16 incentives/cards,
therefore we get a ranking from 1…16 for each
person

Conjoint Analysis
¾

¾

The column “Card_” shows the numbering of the
cards
The column “Status_” can show the values 0, 1 or 2.
incentives that are part of the reduced design get the
number 0
A value of 1 tells us that the corresponding card is a
so-called “holdout card” that isn’t used for the
estimation of the utility values, but for validation.
A value of 2 indicates a simulation card that isn’t
presented to the interviewed persons

Conjoint Analysis
 Rating of the incentives
Possibilities:
¾ Ranking
¾ Rough classification into groups of different utility
with succeeding ranking within these groups.
Aggregation of these results leads to a total
ranking. Used when there is a large number of
incentives.
¾ Rating scales
¾ Paired comparison

Conjoint Analysis
 Estimation of the utility values
¾

¾

¾

¾

Conjoint Analysis is used to determine partial
utilities (“partworths”) β for all factor values based
upon the ranked data
Furthermore, with this partworths it is possible to
compute the metric total utilities y of all incentives
and the relative importance of the single object
attributes
Individual Conjoint Analysis: For each person utility
values are computed
Combined Conjoint Analysis: Only one value for
each factor category

Conjoint Analysis


Estimation of the utility values
¾

The additive model of the Conjoint Analysis is defined as:
yk =

Mj

∑∑ β
J

jm ⋅ x jm

j =1 m=1

with

yk : estimated total utility for incentive k

β jm
⎧
⎪
⎨
⎪
⎩

: partial utility for value (category) m of factor j

x jm = 1 if incentive k has value m of factor j
0 else

Conjoint Analysis
 Estimation of the utility values
¾

¾

¾

Target criterion for the determination of the partial
utilities: The resulting total utilities should yield a
good representation of the empirically ranked data
Related procedure for the determination of the
partial utilities: monotonous analysis of variance
Metric solution → metric ANOVA
Non-metric solution → monotonous ANOVA (not
covered here)

Conjoint Analysis
 Estimation of the utility values
¾

Model for the metric solution
yk = μ +

Mj

∑∑ β
J

jm ⋅ x jm

j =1 m=1

Steps needed to get the solution:
1.
2.

Determination of μ (= average of all ranks)
Determination of the mean rank for each factor
value (= which ranks did the interviewed person
assign on the average in conjunction with this
attribute?)

Conjoint Analysis
 Estimation of the utility values
3.

4.

¾
¾

The average utility of a factor value then equals
the difference of its average empirical rank value
and μ
The partial utilities β are OLS
Now it is possible to compute the total utility of
the incentives

Missing values are being replaced by zeroes
There shouldn’t be too much missing values in
order to prevent the analysis from breaking down

Conjoint Analysis
 Aggregation of the utility values
¾

For the comparability of the individual analyses of
the single persons it is necessary to carry out a
standardisation:
1. The factor value that yields the lowest utility
contribution is set to zero
2. The differences between the single partial utility
values and the lowest partial utility value are
computed:

β *jm = β jm − β jMin

Conjoint Analysis
 Aggregation of the utility values
3.

The total utility value of the incentive that shows
the strongest preference among all persons is
set to one. The partial utility values are computed
accordingly:
βˆ jm

=

β *jm

∑ max {β }
J

J =1

¾

m

*
jm

The importance of an attribute for the preference
change results from the utility range of the several
values of the attribute

Conjoint Analysis
 Aggregation of the utility values
¾

¾

A high range value means that by varying the
concerning attribute a meaningful change of the
total utility can occur
The relative importance of a factor can be obtained
by weighting on the sum of the ranges

Conjoint Analysis
 Aggregation of the utility values
¾

¾
¾

¾

The largest standardised partial utility values allow
to make a statement about the relative importance
of the attributes at the same time
Aggregation always implies the loss of information
If the aggregated utility structures are highly
heterogeneous, this loss of information is
substantial
In this case, more homogeneous subgroups should
be formed by performing a Cluster Analysis
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Example (cont.): Attitudes towards dishwashing
products
¾ There is no graphical user interface available in
SPSS that would allow the performance of a
Conjoint Analysis. The SPSS-Syntax has to be used
in order to retrieve the required procedure
CONJOINT.
¾ After the Syntax-window has been opened, the
following commands should be entered:

Conjoint Analysis


Example (cont.): Attitudes towards dishwashing
products

Conjoint Analysis
The commands in the syntax have the following
meaning:
¾

¾

With the TITLE – statement it is possible to define a title
for the results in the output window
The actual Conjoint Analysis is performed with help of the
procedure CONJOINT. There are various subcommands
within this procedure:
-

The PLAN subcommand tells CONJOINT which file
contains the data for the reduced design
Each of the following commands is preceded by a slash (/):

Conjoint Analysis
-

-

-

The subcommand DATA tells CONJOINT which file
contains the rankings of the respondents
FACTORS is used to define the relationship between the
factors and the preference values (ranks) of the interviewed
persons. The relationships can be DISCRETE, LINEAR,
IDEAL or ANTIIDEAL. In this example, all of the
relationships are DISCRETE because only categorical data
is used. It means that no assumptions are made concerning
the relationship between variables and ranks.
The subcommand RANK tells CONJOINT that the data is
coded in such a way that the sequence of the variables
corresponds to the sequence of the cards

Conjoint Analysis
-

¾

¾

Alternatively, the subcommands SCORE or SEQUENCE
can be used.
By the UTILITY subcommand, a file with the name
“Utility.sav” is being created, where various information is
saved. This information contains the following variables:
• CONSTANT: The constant term of the conjoint
estimation
• Several partial utility values
• SCORE1 to SCORE16: Total utility values of the
reduced design

With the SUBTITLE command, a new subsection of the
output is introduced
With the “get file” statement the contents of the
“Utility.sav” file are printed in the output window

For our example, the results would be the following:

Conjoint Analysis
 Interpretation of the results
¾

¾

¾

The term “Averaged importance score” under the
box with the importance values tells us that a
Combined Conjoint Analysis has been performed.
These values give us a measure (in percent) of the
relative importance of the single factors for the
determination of the utilities. We can see that
“quantity” is the most important factor whereas
“shiny” is the least important.
The Correlation coefficients are a measure for the
quality of reproduction of the empirical data by the
results of the Conjoint analysis.
The estimated partial values for the factor values
are given in the column “Utility Estimate”

Conjoint Analysis
 Interpretation of the results
¾

¾

Summaries of Importance and Utility in form of bar
charts are also given
The partial utility values allow the computation of
the total utility values for all the incentives. For
example, the total utility value for card 1 would be:
8,96-0,23-0,23-0,08+0,83+0,43-0,62=9,06

¾

The constant term μ can be interpreted as base
utility, and the other factor values contrast with μ in
positive or negative direction

Conjoint Analysis
 Interpretation of the results
¾

Following this, the total utility values for all the cards
can be computed similarly. Like it was said above,
the results of this computations can be found in the
“Utility.sav” file (Score1 to Score16):

Conjoint Analysis
 Interpretation of the results
¾

¾

We can see that card 2 has the highest total utility
(10,82). A product that makes the dishes clean, the
glass shiny, has a lemon-fresh smell, a multicolored design and is packaged loose in a medium
sized box therefore is the most preferred product
out of the 16 alternatives.
Here, just the results for the reduced design are
given. But it is also possible to compute total utilities
for all the products of the complete design, even
though they were not part of the interview.

Conjoint Analysis
 Interpretation of the results
¾

It is therefore possible to find out that, for example,
a product that is similar to card 2, except that the
box contains single packaged tabs, would have an
even higher total utility than card 2.

Conjoint Analysis
 Clustering the partial utility values
¾

¾

As aforementioned, a Cluster Analysis should be
performed before aggregating the results if the
aggregated utility structures are not homogeneous
To get the data that is needed to do this, a new line
has to be inserted into the syntax:

Conjoint Analysis
 Clustering the partial utility values
¾

The results for each person are computed and
saved into the file “Person Utility.sav”:

Conjoint Analysis
 Clustering the partial utility values
¾

Now the formulae given in the section “Aggregation
of the utility values” are used to calculate the
standardised partial utility values (Transform >
Compute). It is reasonable to do this in two steps:
1. Compute the differences between the single
partial utility values and the lowest partial utility
value:

Conjoint Analysis
 Clustering the partial utility values
2.

¾

Set the most preferred incentive to 1 and
compute the standardised partial utility values
accordingly:

These two steps have to be repeated for each factor
value. After that, the partial utility values and the
standardised partial utility values can be attached to
the original data file

Conjoint Analysis
 Clustering the partial utility values
¾
¾

To do this, use Data > Merge files > Add variables
If both data files are opened and the original data
file is the active one, the option “An open dataset”
can be chosen. Otherwise there is the possibility to
browse for the corresponding file:

Conjoint Analysis
 Clustering the partial utility values
¾

We can exclude variables from the dataset that
aren’t needed anymore (i.e., the SClean1 to
SDesign3 variables). The variables that aren’t
excluded form the new data set:

Conjoint Analysis
 Clustering the partial utility values
¾

The next step is the actual performance of the
Cluster Analysis using the menu Analyze >
Classify > K-means Cluster

Conjoint Analysis
 Clustering the partial utility values
¾

¾

¾

¾

All the standardised variables from NClean1 to
NDesign3 are used as input
To save the results of the Cluster Analysis in the
data file, the box “Cluster Membership” in the
“Save”-menu has to be checked
It is necessary to try different numbers of clusters to
find out what the (as regards content) best solution
is
Cross-classifying the variable for the Cluster
membership with certain demographic variables is
needed to assess the best Cluster solution

Conjoint Analysis
 Clustering the partial utility values
¾

If the Cluster solution has finally been found, it is
possible to compute an Combined Conjoint Analysis
for each Cluster separately (using Data > Select
Cases)

